MoTeC UTC USB to CAN

MOTEC UTC
USB to CAN adapter (includes USB cable)

Software Requirements for UTC Compatibility
M400, M600, M800, M880 - V2.30S or later
M84
PDM16, PDM32, PDM15, PDM30 - V1.0 or later
BR2 - V1.0.6.2 (this software ships with all data logging manager software)
DBW4 - V1.03 or later
SDC, SDC2, SDC3 - V1.21 or later
MDC - V1.22 or later
MDC2 - V2.0 or later
LTC - V1.0 or later
ADL - V3.20P or later

Note: RTC is not compatible with MoTeC's UTC. Connect to the PC's parallel port instead. If the PC does not have a parallel port MoTeC can configure this device for you.

 


Related Items